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1. INTRODUCTION

Airrad’ is an IBM PC-based fallout prediction system. It
incorporates a state of the art windowing system which
allows operation of the model with a minimum of user
preparation. Only data readily available in the field is required
as input. Specific features include...

An estimation algorithm for estimating missing wind data.

The ability to compute a variety of fallout hazard indicators,
including normalized exposure rate, integrated dosage, and
approximate beginning and ending fallout times.

Specific receptor support, which allows all hazard indicators to be
computed at a user defined set of specific points in addition to the
grid.

The ability- to create a contour plot for any selected hazard
indicator and time, and display it using either a video screen or a
plotter.

The capability to plot contours directly onto a user-supplied map.
The ability to enter locations of the burst and specific receptors
from a user-supplied map, using either a digitizing pad or the

digitizing mode of a plotter.

A map digitization utility, which allows the user to enter a map and
later use it to annotate contour plots on the screen.

Extensive online help, which is context sensitive and cross-
referenced.



- A path dosage integration routine, which allows computation of the
total radiation dosage experienced while moving along a path.

example, the total dosage received by an aircraft flying a user
defined flight path may be calculated.

For



2. SYSTEM CONSIDERATIONS

Required minimum system

IBM PC, XT, AT, PS/2, or compatible with 512k RAM and numeric
coprocessor.

Recommended minimum system

IBM AT or PS/2 with 512k RAM, numeric coprocessor, hard disk, EGA
or VGA graphics card, color monitor, one asynchronous
communications port, and an HP GL plotter.

Supported peripherals

- HP GL plotter
IBM 749 plotter
CalComp 2000 digitizing pad
Kurta 1S/One digitizing pad
Microsoft compatible mouse

If your version of the Airrad distribution includes the source code and you
wish to compile the program, you will need a copy of Turbo Pascal 4.0.



3. HARD DISK INSTALLATION

It is recommended that Airrad be installed on your hard disk. To do so,
follow these steps.

}_1. Insert the first Airrad distribution disk .into a drive.
letter designation of the drive which you are using to read the

distribution disk. For example, to install Airrad using the A:
drive to read the distribution disks, use the following command.

2. Type #\install and press Return, where # is replaced wi{th)he one

a:\install

3. Follow the instructions given by the install program.



4. TUTORIAL IN RUNNING AIRRAD

TARTING THE P RAM
Start Airrad by typing 'air' and pressing enter.

When the program begins, an information page will be displayed, which
lists the Airrad version number, its author, the agencies which sponsored
its development, and a contact to whom all questions and distribution
requests should be directed. Press any key to continue.

WINDOWS

Notice the rectangular area at the top of the screen, which surrounds the
words File, Edit, etc. This area is known as a window. Other windows
currently visible on the screen contain burst information and a wind
profile. A window is simply an area of the screen through which Airrad
communicates with the user. The window you are now viewing is known
as the top level, or main, window.

All the windows we can currently see are text windows, meaning that
they contain only printed text. Graphics windows also exists, but we will
not concern ourselves with them for the present. Whenever the word
window appears, assume that it refers to text windows. The word menu is
sometimes used as a synonym for the phrase text window. The two terms
will be used interchangeably.

At any given time, several windows may be visible, but only one is active.
All user-Airrad dialogue takes place through the active window. The
active window will always be -distinguished by the presence of the color
bar (see 4.3 below).

The green rectangular window at the bottom of the screen is known as the
information window. |t always contains a short summary of special



information about the active window. If you're ever unsure as to which

key

THE

The

to press, check the information window.

LOR

color bar is the short red bar in the top level window, which initially

highlights the word File. It functions as a type of cursor, moving from
entry (occurrence of text) to entry in a window. The color bar always
appears in the active window. It is used to select which action the user
wishes to perform, or which item of data the user wishes to edit. The
color bar can be moved about the active window by using the following
keys...

The

Right Arrow - Move the color bar one entry to the right.
Left Arrow - Move the color bar one entry to the left.

Up Arrow - Move the color bar to the next entry above the current
one.

Down Arrow - Mgveﬁthe color bar to the next entry below the current -
‘one. ‘

PgDn - Move the color bar one page down.

PgUp - Move the color bar one page up.

Home - Move the color bar to the upper left window entry.

End - Move the color bar to the lower right window entry.

arrow keys cause the color bar to wrap around the outside edge of the

window. For example, suppose the color bar is in a window with entries

laid

out as shown below...

EntryA1 EntryB1
EntryA2 EntryB2
EntryA3 EntryB3

Now assume the color bar is highlighting EntryA3. If the user presses the
down arrow key, the color bar will move to EntryB1. |f the user presses
the left arrow key, the color bar will move to EntryB2. ‘
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MOVING BETWEEN WINDOWS

Press the right arrow key. The color bar should move one space to the
right, and highlight the Edit entry. Press the Enter key now, to tell Airrad
that you wish to edit data.

Note how the original menu was replaced with a new menu. The original
menu is still there; it is simply covered by the new active window. Now
press the Esc (escape) key. The original menu will reappear. In this
manner, going forward by selecting an entry and pressing Enter, and going
back with Esc, any Airrad window can be reached and made active.

Suppose we now wish to go into the option menu. One method of doing so
would be to press the right arrow key several times, until the color bar
highlighted Option, and then to press Enter. However, a shortcut exists.
Note how one letter in each window entry is highlighted ( The F in File,
the E in Edit, etc.). These letters can be used to quickly select the option
associated with each entry. Press the 'O' key on the keyboard (upper or
lower case). The Option menu will appear, just as the edit menu appeared
above.

In general, pressing a key corresponding to a highlighted letter in a entry
in the active window, is equivalent to moving the color bar until it
highlights that entry and pressing Enter.

Now return to the top level menu (Press Esc), and go into the edit menu
again (Press 'E").

We will now make the burst window active. Press the 'B' key. The color
bar should appear in the burst window, directly below the edit window. At
this point, the burst window is active. Pressing the Esc key will return us
to the edit window, and pressing Esc a second time will make the top level
menu active. We could also return directly to the top level menu by
pressing the F10 key. The F10 key can be used from any standard window
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in Airrad, and is equivalent to pressing the Esc key sufficiently many
times to make the top level menu active. This is an example of a hot key:
a single key set up to do a specific function. Hot keys will be discussed in
greater detail below.

Press the Esc key twice, until the main menu is active, and the return to
the burst window by typing 'EB'. Now go directly to the main menu by
pressing F10. Again return the the burst window.

DATA WINDOWS

The top level and edit windows are both selection type windows - they
allow the user to select an action from a list of alternatives. Now look at
the burst window. It is a data window, which allows the user to enter
and/or edit information. The color bar should be highlighting the numeric
part of the Burst Yield entry. If it is not, use the up and down arrow keys
until it is. No;j type '100' and press Return. You have just told Airrad that -
the total yield of the burst you wish to model in 100 kilotons. -Entering
data into Airrad is as simple as that.

There are three types of data entries which can appear in a window:
numeric, text string, and toggle. At least one of each of these types of
entries appears in the burst window. We will study each type in turn.

TOGGLE WINDOW ENTRIES

The simplest type of data entry is the Toggle, which allows the user to
select one of a small set of possible alternatives. Move the color bar to
the Fission Type entry. Press Enter several times. Note how a new fission
type appears each time you press Enter. Continue to press Enter until the
fission type you desire appears. The Space Bar and Tab key will also
advance the list one element, while the BackSpace and Shift Tab keys will
display the list in the opposite order.

N



Choosing Estimate for the fission type will cause Airrad to make an
estimate of the fission type based on the fission yield.

[EXT STRING WINDOW ENTRIES

Move the color bar down to the Burst Time entry. This is a text string
entry - it allows the user to enter an arbitrary sequence of characters.
Type in '12:30' and press Enter.

A previously entered text entry can also be edited without retyping the
whole entry. As an example, we will change the burst time to 12:35.

1. Press Enter (enter text editing mode).

2. Press the right arrow key until the small, flashing cursor in under
the 0.

3. Press del (delete) key to erase the 0.

4. Press 5. |

5. Press Enter (leave text editing mode, accepting changes)..

Alternative method.

1. Press backspace (enter text editing mode and erase last non-blank
character).

2. Press 5.

3. Press Enter (leave text editing mode, accepting changes).

The small, flashing, underline cursor will always be present whenever
Airrad in in text editing mode. Note that some keys, such as the arrow

keys, produce different effects when Airrad is in this mode.

To edit text, position the color bar over the text string entry in question,
and enter text editing mode by pressing one of the following keys.

Enter - Cursor appears under the first character in text. .



Delete - First character in text erased. Remaining characters shifted 4
one space to the left. Cursor appears under first character.

Backspace - Last non-blank character in text replaced by blank space.
Cursor appears under this space.

Any alphanumeric character - Entire string erased and replaced by the
typed character. Cursor appears to right of this character.

Once in text editing mode, the following keys have special meanings.
Alphanumeric - The typed character is inserted into the text string at
"’th‘e\\position of the flashing cursor. Note that the cursor is always in
insert, as opposed to overwrite, mode. This means that the text under
and to the right of the cursor is shifted one space to the right to make
room for the new character.

Left and Right Arrows - Move the cursor one character left or right.
Backspace - Erase character to left of cursor.

Delete - Erase character under cursor.

Home - Move cursor to beginning of text field.

End - Move cursor to end of text.

Ctrl Left Arrow (Left arrow while holding down Ctrl key) - Move
cursor one word left.

Ctrl Right Arrow (Right arrow while holding down Ctrl key) - Move
cursor one word right.

To leave text editing mode, press one of the following keys.




Enter - Leave text editing mode, ‘accepting changes to text. The small,
flashing, underline cursor will disappear, and the arrow keys will
once again move the color bar.

Up and Down Arrows - Has same effect as pressing Enter followed by
the arrow key. Terminates text editing, accepts changes, and move
color bar up or down. This is useful when entering data into a column;
it saves a keystroke.

Esc - Leave text editing mode, canceling all changes and restoring
original text. This is useful if you make an editing mistake and wish
_to start over.

NUMERIC WINDOW ENTRI

Press Enter to leave text editing mode, if you have not already done so,
and move the color bar up to the height of burst entry. This is a numeric
entry. It is similar to a text string entry, with two exceptions.

Arbitrary text cannot be entered into a numeric entry. The text must
comprise a number, and the number must fall within a certain range. As
an example, '100' could be entered as a legal text string for the burst
height entry. However, 'xyz' would not be accepted, since it is not a
number. '-100' would also be rejected, since Airrad does not perform
subsurface event calculations, and sets a minimum bound of 0.0 for the
burst height entry.

Most numeric entries have units associated with them. These units can be
changed to match the user's data. Use Tab and Shift Tab to toggle the
units. The numeric entry text will be updated to reflect the new units.
The desired units can also be incorporated directly into the text string
when a new numeric value is entered. Most common abbreviations will be
recognized. For example, it would be acceptable to enter '100 ft' for the
burst height entry.

11



Some numeric entries, such as the number of grid points, are 'pure
numbers' and thus do not have associated units.

Try experimenting with the burst height. Use the Tab key to change the
units, and enter illegal or out of range text strings to observe the effect.
Note how an acceptable range is given whenever an out-of-range error is
displayed.

NLIN

Airrad has an online help facility which can be called up at any time using
the F1 key. The help is context sensitive, meaning that the help topic
displayed when F1 is pressed will relate to the entry which the color bar
is currently highlighting.

AltF1 (F1 while holding down the Alt key) will display the last help topic
accessed. By repeatedly pressmg AItF1 you can back up through the last
20 help topics.

CtrlF1 (F1 while holding down the Ctrl key) will display an index of help
topics. Move the color bar to the topic of interest and press Enter to
display the associated help page.

Many help topics have cross-references. These are areas of text, printed
in black, which can be used to rapidly access related help topics. Simply
move the color bar to a topic and press Enter.

Some help topics occupy more than one page. You can move back and forth
with the PgUp (Page Up) and PgDn (Page Down) keys. The symbols PgUp
and/or PgDn will appear in the lower right corner of the help window when
appropriate.

Press the Esc key to terminate a help session and return to your previous
position in the Airrad windows.
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As an example, suppose you're not sure if the height of burst entry is the
height above ground level or sea level. Move the color bar to the height of
burst entry and press F1. The help screen answers your question, but
while reading it you notice the numeric entry cross reference. Move the
color bar down to it and press Enter. The first page of the numeric entry
help topic is displayed. Note the PgDn symbol at the bottom of the
window. This informs you that there is additional information on a
succeeding page. Press PgDn to access it. PgUp can be used to back up to
the preceding page. Now press AltF1 to return you to the height of burst
help screen. Press CtrlF1 to access the help index. Browse if you like.
Don't worry about gettrnd lost in the help screens - you can always return
to the index with CtriF1, or exit the help session with Esc.

BURST WINDOW TUTORIAL SETTINGS

You should now be able to correctly enter data into the burst window. Go
through and set the burst window entries to the following values

Entry _ Type : Value
Total Yield Numeric 100 kt
Fission Yield Numeric 100 kt
Fission Type Toggle Estimate
Height of Burst Numeric 10 m
Altitude of GZ Numeric 200 m
Burst Time Text String 22:30
Burst Date Text String 8/23/88

If you are not sure of the meaning of a particular entry, use the online help
feature.

WIND DATA WINDOW

Back up to the edit window (press Esc) and go into the wind window
(press 'W').
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The wind window allows the user to enter a vertical profile of wind
conditions at the burst site. Each horizontal row represents a level at
which you know the wind speed and/or direction. Enter the height of each
level in the far left entry, and the wind speed and direction in the next
two columns. These are all standard numeric entries. Press the Ins
(Insert) key to create a new blank row just below the row which contains
the color bar. Press AltD ('D' while holding down the Alt key) to delete the
row which contains the color bar.

A maximum of 20 rows are allowed. Press the Ins key several times, until
the screen fills with rows, then continue to press. Note how the old
entries in the window scroll out of the window to accommodate the
additional entries. The old entries are still there: they are just
temporarily not visible. You can scroll them back onto the screen by using
the up arrow key. Practice moving around in this window, going to entries
which may be temporarily invisible. In particular, note the effects of
PgUp and PgDn. You may need to enter a few dummy values into some of
the entries, so that all the rows are not identical, to observe the scrolling
effect. ' :

Note that the text string for all entries is initially '--'. This means that
the values are undefined. To define them, simply move the color bar over
the entry and type in the desired value. To undefine a previously defined
entry, enter '--' for the numeric text string.

It is allowable to leave entries undefined if you so desire. Rows with
undefined heights are simply ignored. In rows with undefined speeds or
directions, however, the missing data is filled in using an estimation
algorithm when the case is run. This is useful if, for example, one knows
the wind direction at a certain height but not the speed.

It is allowable, although strongly discouraged, to leave all data in this

window undefined. In such a case, the estimation algorithm defaults to an
average mid-latitude continental wind profile.
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Press Ins or AltD until five rows are displayed, and try entering the
following wind profile. The down arrow method for terminating text
string editing mode is quite useful at this point (see Text String Entries
above). Note how the color bar wraps around to the top of the second
column when it goes off the bottom of the first.

Height (m) Speed (mph) Direction (deg)
1 5 180
1000 10 190
10000 15 200
20000 20 210
30000 25 220
GRID WINDOW

Back up to the edit window and go into the grid window.

The grid window allows the user to define the size and location of the grid
of points for which fallout ‘calculations will be performed. All entries in
this window are of numeric type. The coordinates of the grid corners and
ground zero can be in any system of units, the only restriction being that
it must be a Cartesian coordinate system with the positive Y axis pointing
true north, and the positive x axis pointing east.

The number of X and Y grid points can each have any value between 2 and
40. It is recommended that both values be left at 40 for maximum
resolution, unless computational speed is of great concern.

The SW Grid Point entry is the location of the southwestern most grid
point [1, 1]. The NE Grid Point entry is the location of the northeastern
most grid point [<Max X Grid Point>, <Max Y Grid Point>].

If any or all of the grid corners entries are left undefined ('---"), an
algorithm will be employed when the case is run to determine appropriate
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values for the grid corners, such that the most significant portion of the
fallout footprint is displayed. '

Try setting the entries in the grid window to the following values.

_ X (East) Y (North)
Number of Grid Points 40 40
SW Grid Corner = c----c-0 aeaaa--
NE Grid Comner = c-e---- aeaoa..
Burst Location 0 km 0 km

SPECIFIC RECEPTORS WINDOW

Back up to the edit window, and go into the receptor window.

Up to 40 named specific receptors can be defined. These are specific
points for which fallout calculations are performed, in addition to the
grid.

Each horizontal row in the receptors window corresponds to one receptor.
The name of the receptor is entered in the first column, and the X and Y
coordinates are entered in the last two columns. These coordinates must
be the in the same system of coordinates used for the grid origin and burst
location above.

Press the Ins key to create a new row. Press AltD to delete a row. This
works in the same manner as the wind window described above.

Press Ins or AltD until three rows are displayed, and practice entering the
following data...
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Receptor Name X Location Y Location

'Test Receptor 1 - Ground Zero' 0.0 km 0.0 km

'Test Receptor.2 - Downwind Point -1.0 km 5.0 km

'Test Receptor 3 - Upwind Point' 0.0 km -5.0 km
COMPUTATIONAL OPTIONS

Go to the top level window (press F10), and into the options window
(Press 'O'). The options window contains settings which control how
Airrad computes and displays its results. Go into the computational
options window (Press 'C).

All of the entries in the computational options window are of type toggle.
Move the color bar to each entry and press F1 (help key) for a description
of the purpose of each of the options. Then practice setting them to the
following values...

Calculate Concentrations : 2 sigmas out from puff centers

Do Calculations Using : every fourth particle size class
Number of Cloud Subdivisions 1 2

PERFORMIN MPUTATION

All data necessary to define an Airrad case has now been entered. The
case can now be run. Go back to the top level menu (Press F10). Choose
'‘Compute’ from the list of options. The fallout grids will be computed.
Notice the colored bar which crosses the bottom of the screen twice. It
gives an indication of progress in the computations.

At any time, the computations may be aborted by pressing any key.
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HAZARD WINDOW

Now that the case has been run, we will display the results. Select 'Show'
from the main menu. Then select 'Hazard'.

The Hazard Window allows the user to select which hazard indicator to
view, and the manner in which it is displayed.

Suppose we wish to see a contour plot on the screen of the ground level
dosage rate at time H+2 hours, in units of rads per hour.

Move the color bar down until it highlights 'Exposure Rate at time T1', and
press Enter. Note that the plot is not displayed: rather, the bracketing
symbols >> << move down to mark our selection. This indicates that when
we do make a plot, it will be an exposure rate plot.

Now we will set the time, T1. Move the color bar to the 'T1 H +' entry, and
enter '2:0' (2 hours, 0 minutes). Notice how the T1 time and date entries
are updated. We could also have entered the time and date directly, and
the H + time would have been properly updated. Recall that we entered the
burst time and date in the burst window. They are used to find the
correspondence between the H + and absolute times.

Move the color bar to the Rad Units entry. This is a toggle entry, so press
Enter until the desired radiation metric, Rads, appears.

The Height entry is the height above the ground at which the hazard
indicator is calculated. This can be used to calculate conditions
experienced by a plane at a given altitude. Since we want a ground level
plot, set this entry to 1 meter.

Move the color bar up to the Graphics Screen entry and press Enter. Again,
the flanking >> and <<'s move to mark our selection.

All pertinent information in the hazard window has been set, so we can
now produce the plot. Press the F9 key. The screen will go into graphics
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mode and display a set of contours. The legend at the right gives the type
of plot, the contour levels, the case name, the date and time when the case
was run, and a scale.

To return to the hazard window, press Enter, Esc, or the space bar.

HOT KEYS

The F9 key we pressed in the previous step is known as a global Hot Key.
A hot key performs a special function whenever it is pressed. For
example, the F9 key displays the plot selected by the current settings of
the hazard window entries.

The F9 hot key is considered global because it works from almost
anywhere in the Airrad window system. You could press F9 in the top
level menu, the burst window, or almost anywhere else, and it will have
the same effect. Of course, you will have to enter the hazard window and
change its settings to view a different kind of plot.

Local hot keys also exists. They function in only a small number of
windows. Local hot keys will always be mentioned in the information
window at the bottom of the screen. They will be discussed in the manual
sections concerning the windows in which they function.

There are a few times when hot keys are disabled: whenever an error or
message box is active, or a plot is displayed.

Below is a list of the global hot keys defined in Airrad. In the key list,
Alt# and Ctrl# represent pressing the # key while holding down the Alt
and Ctrl keys, respectively. Window locations are indicated in a special
abbreviated form: >Edit>Burst refers to the burst window, which is
accessible through the edit window.
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Key Function

F1 - Display a help screen relating to the entry currently
highlighted by the color bar.

F2 - Save the current Airrad case to a disk file. User will be
prompted for a file name. Same as >File>Save.

F3 - Load a previously saved Airrad case from a disk file. User
will be prompted for a file name. Same as >FilesLoad.

F8 - Unconditionally compute the current case. Same as AItC
and >Compute.

F9 - Display the plot selected by the settings in the hazard
window. If necessary, run the case first.

F10 - Go the the top-level, or main, menu.

AltA - Align a map on an external device, prior to entering
coordinates (will be discussed below). Same as >Align.

AItB - Go to the burst window, >Edit>Burst.

AltC - Compute the current Airrad case. Same as F8 and >Compute.

AltE - Go the the edit data window, >Edit.

AItF - Go to the file window, >File.

AltG - Go to the grid parameters window, >Edit>Grid.

AltH - Go to the hazard window. Same as >Show>Hazard, except

the case is not automatically run.
AltM - Go to the map window, >Map.

AltO - Go to the options window, >Option.

AltQ - Quit Airrad and return to DOS. Same as AltX and >Quit.

AltR - Go to the receptor window, >Edit>Receptor.

AltS - Go to the show window, >Show. If necessary, run the case
first.

AltW - Go to the wind window, >Edit>Wind.

AltX - Quit Airrad and return to DOS. Same as AltQ and >Quit.
AltF1 - Back up to the last help topic accessed.

CtrlF1 - Go to the help topic index.
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SAVING A CASE

We will now save this Airrad case to a disk file. Go back to the top level
window, and into the file window (Press F10 then 'F'). Select Save. You
will be presented with a window consisting of one text string entry, and a
message prompting you to enter your desired file name. A default name
will already be present. At this point, you can use the default by simply
pressing Enter, or go into text editing mode by pressing the left or right
arrow key. Note that this is different from most other text string entries,
in which Enter initiates text editing mode.

DOS file names are comprised of three parts: the directory path, the base
name, and the extension. In the file name 'c:\airrad\testfile.dat',
‘c:\airrad\' is the directory path, 'testfile’ is the base name, and '.dat' is
the extension. The base name can be up to 8 characters long, and the
extension must be a period followed by 1 to 3 characters.

You must supply the base name. The directory path s optional; the current
directory is assumed if one is not supplied. ‘Do not attempt to specify the
extension in the file name you enter; it will be automatically supplied.
The case will actually be stored in three files: #.ard, #.cfg, and #.grd,
where # is the directory path and base name you supply.

Type 'testcase' and press Enter.

STARTING A NEW CASE

Make sure you have saved the case described in the previous step, because
you will now destroy the copy of the case currently residing in Airrad.

Go to the file window and select New. All the Airrad entries will be reset

to their default values. Note how the burst date and time are set to the
current date and time, as given by the internal system clock.

21



ADING A PREVI Y SAV

Select Load from the file window, or press the hot key F3. You will be
presented with a file name input box like the one you saw when you saved
the case above. At this point, you could type in the file name you used, and
the case would be reloaded.

However, let's assume that you cannot remember the exact name. Type in
a directory name and press Enter. Use '.' for the current directory. Airrad
will respond with a menu listing all the Airrad cases in that directory, as
well as a list of all subdirectories. The cases are listed in order of
creation date, from the newest to the oldest. Move the color bar over an
Airrad case and press Enter to load it. Select a directory name to change
into that directory. Select '..' to move back into the previous directory. In
the manner, you can search for and then load any Airrad case on disk.

Press any letter key to move the color bar to the next entry in the menu
which begins with the selected letter.

Reload the case you saved above.

USE OF THE ESCAPE KEY

Suppose you accidently hit the F3 key, which puts Airrad into the save file
window. To get out of the save case mode and return to your previous
location in Airrad, press the Esc (Escape) key.

The Esc key function as a general purpose abort key. If you ever perform
an action and wish you hadn't, try pressing Esc. Esc can terminate a
partially completed computational run or plot, go back a level in the
windows, restore a text string or numeric entry which is being edited, or
abort a special operation such as loading a case. '
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RUNTIME LISTING

Go to the >Options>Listing window. Note that the highlighted letter in
Listing is 'T', not 'L'. Airrad is capable of creating a run time listing
which documents its computations. This listing can be displayed on the
screen, or sent to the printer or a file. Select Screen for the destination,
and run the case again using the F8 hot key. The listing will scroll by in a
screen-size window. It can be temporarily halted with the Scroll Lock
key. Press it once to stop, and a second time to restart. You may wish to
run Airrad again, sending the listing to a file, which you can later study at
your leisure. The listing contains a wealth of information concerning the
blast.

PERIPHERALS WINDOW

Before we can use an outside peripheral device, such as a plotter or a
digitizing pad, we must tell Airrad how to communicate with the device.
-Go to the >Options>Peripherals window. Select the type of plotter and pad
you will be using, and set the communications parameters to their proper
settings. All entries are of type toggle. Refer to your computer's
hardware manual, and the peripherals’ manuals, for more information on
selecting the proper values for these entries.

USING A PLOTTER

Hook up your plotter, turn it on, and prepare it for plotting. Insert a blank
sheet of paper.

Press AltH to get into the hazard window. Move the color bar till it
highlights Plotter Contours. You could press Enter to move the >> << before
pressing F9, but this is not necessary. As a shortcut, F9 will
automatically move the >> << to the location of the color bar. b
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Press F9. The plotter should respond by réproducing the plot you saw
earlier on the screen.

TEXT SCREEN PLOT

Move the color bar to Text Screen Contours and press F9. You will see a
stylized representation of the contour map using the text screen. This is
useful as a quick check of the general footprint shape, or on a computer
without graphical capabilities. It is also the most pleasing method for
viewing fallout start and stop time plots.

MPUTIN AS INSID NTOUR

Select Contour Areas and press F9. A window will appear, listing the
contour levels and the area inside each, in square meters, feet,
kilometers, and miles. Note that it is the user's responsibility to insure
that the computational grid (set in the >Edit>Grid window) _complete’ly
surrounds the contours of interest. A good method of checking this is to
take a look at the graphics screen contour plot. Only the contour area
inside the grid is calculated, so if part of a contour extends beyond the
edge of the grid, the displayed area will be low.

ISPLAYING SPECIF T I

Select Specific Receptors and press F9. The value of the currently
selected hazard indicator will be displayed at each of the specific
receptors defined in the >Edit>Receptor window. If more than one page of
receptors exists, PgUp and PgDn can be used to browse back and forth
through the list.

Press Esc to return to the hazard window.
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ECTIN NTOUR LEV ND COLOR

Look at the list of different hazard indicators. They fall into three basic
categories - exposure rate measures, total dose measures, and time
measures.

Go to the >Options>Plot window. Note the first 3 entries in the Plot
Options window: Rate Contours, Dose Contours, and Time Contours. This is
where we select the contour levels and colors for each of these three
types of hazard indicator contour plots.

Go into the Rate Contour window. Note that it is comprised of rows, one
per contour level, which give the value of each contour and the colors and
symbol associated with it. New rows can be inserted and existing rows

deleted with the Ins and AItD keys respectively, just like in the wind and
receptor windows discussed earlier.

The Contour Color column lists the colors with which contour lines of this
row's value will be drawn on the graphics screen and plotter. Press AltL
to see a list of the legal colors. The colors may be entered either by
typing their name, typing their associated code number (See the AIltL list),
or by using Tab and Shift Tab to toggle through the list. As we can see,
the colors entries are combination Text String/Toggle entries.

The Text Mode Color entries operate exactly like the Contour Color entries.
They represent the colors of the text blocks used when Text Screen
Contours are produced.

For monochrome monitors, a symbol contour plot is provided. It uses the
text mode, but creates its display out of different characters instead of
different colors. The Text Mode Symbol column allows an alphanumeric
character or symbol to be associated with each contour level. To get |
Airrad to display a symbol contour plot, select Symbols from the Display
Text Mode using toggle entry at the top of the window, then produce a Text

Screen Contours plot.
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Go back to the >Option>Plot window. The Dosage Contours and Time
Contours windows work like the Rate Contours window, with the

exception that the level values in the Time Contours window are not
specified as floating points numbers, but rather in the format d:h:m, where
d, h, and m are the number of days, hours, and minutes since the burst.

-PLOTTERP IAT

Go to the >Options>Plot>Pens window. This window associates a plotter
pen with each of the colors which may be specified for contour levels.
Simply enter the pen id number after each color. Note that the first pen is
always assumed to have an id number of one; i.e., there is no pen zero.
Since there are 16 colors, and few plotters have 16 pens, multiple
assignments of single pens to several colors will be necessary.

The Map All Colors entries at the top of the window can be used to produce
a monochrome plot. Airrad effectively ignores all other color information,
and uses the specified pen, when this Yes/No toggle is set to yes.

The Legend Pen entry at the bottom of the window sets which pen will be
used to draw a plot border, title, scale, etc.

The Digitizing Sight entry at the bottom of the window tells Airrad the
pen stall in which your plottér's digitizing sight is stored. Set this entry
to undefined ('--') if you keep your sight outside of the plotter, and wish
to insert it into the pen holder only when necessary. The digitizing sight
is a clear plastic crosshair sight which can be used to digitize points with
the plotter. It is useful when plotting contours directly onto a map. More
on this later.

MISCELLANE PTION

Go to the >Options>Plot>Misc window. The Screen Legend and Screen
Background entries control the color of the border, title, scale, etc., and
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the background color of plots drawn on the screen. These entries work
like the Contour Color entries of the >Options>Plot>Rate Contours window,
discussed above. These settings do not affect the plotter - the plotter
legend pen is set in the >Options>Plot>Pens window.

AIRRAD STY NFIGURATION

As noted above, when Airrad writes a case to disk, it stores the case in
three separate files, with the extensions '.ARD', '.GRD', and '.CFG'".

The .ARD file contains information which directly affects the results of
Airrad calculations, or which should be logically associated with a
particular case. This information is known as case data. Examples
include the burst yield, the number of X grid points, and the number of
cloud subdivisions. Specifically, case data consists of the settings of the
Burst, Wind, Grid, Receptor, Align, Map, and Computational Options
windows. If any case data in the Burst, Wind, Grid, Receptor, or
Computational Options windows is changed, the case will have to be rerun
before any plots can be produced. |

The .GRD file contains the calculated radiation intensity grids from which
the values of all hazard indicators can be derived. It is present only if the
case had been run before being saved.

The .GRD file also contains a list of certain ground impact parameters for
each tracked parcel. This information is used to calculate the integrated
dosage received by a plane flying a specified flight plan.

The .CFG file contains configuration data. Basically, configuration data is
any Airrad window setting which is not considered case data. It controls
the manner in which Airrad displays and communicates with the user.
Examples include the settings of units for all numeric entries, the
settings of all the Options windows except for the Computational Options
window, and the settings of the Hazard Window.
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The configuration data is automatically saved and restored whenever an
Airrad case is saved or loaded. In addition, this can be done explicitly by
using >Options>Load and >Options>Save. Do not confuse these with
>File>Load and >File>Save. The Options save and load only save and restore
the Airrad configuration. These options operate analogously to the case
save and load.

The file \Airrad\Data\Airrad.cfg contains the configuration file Airrad
reads when the program is first started, and whenever >File>New is
selected. By changing the configuration and then overwriting this file, you
can customize Airrad to your specific needs. For example, suppose your
met data always lists the wind speed in knots. You could toggle the wind
speed units to knots, and then save the configuration in the above
mentioned file. From then on, the wind speed units would always be knots
when you started a new Airrad case, saving you the trouble of having to
remember to explicitly change them for each new case.

Of course, you could also save and restore the conflguratlon to a flle name
of your own choosing. It is' possible to build up a library " of

configurations, each keyed to a particular situation. You might have a
field configuration, which expects heights in feet and has as its initial
hazard indicator the total dosage in rads, and a lab configuration, which
expects heights in meters and initially creates normalized rate plots in
Roentgens.

As an example, save the current configuration into a file called
'AIRCONFG'. Then go into the >Edit>Burst window (remember the AltB hot
key). Use Tab to change the Total Yield units to Mt. Now restore the
previously saved configuration with >Options>Load. Go back to >Edit>Burst
and note how the Total Yield units have been set back to kt, but that the
actual value of the yield has not changed.
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INPUT DEVICE WINDOW

Until now, we have entered the coordinates of points by typing them in.
Airrad also has the ability to input points from a map, using either a
digitizing pad or a plotter with digitizing capability. Before we can do so,
we must tell Airrad which type of device is to be used. We do so in the
>Options>Input window. Go there now and select either Plotter or
Digitizing Pad, whichever is appropriate. This is a toggle entry.

ALIGNING A MAP ON AN EXTERNA Vi

Make sure the digitizing pad or plotter, whichever you selected in the last
step, is connected, turned on, and set up to communicate according the the
settings in the >Options>Peripherals window.

Get a map which shows the general area surrounding the burst site. The
map does not have to be of any particular scale or orientation. It must,
however, meet the following conditions. '

- The map's coordinate system must be Cartesian. A vector pointing
true north must be perpendicular to a vector pointing true east, at
all locations on the map. Furthermore, two true north vectors
placed anywhere on the map must be parallel. Lastly, the scales in
the north and east directions must be equal. Few maps will violate
this last restriction, but a poorly designed photocopy machine can
introduce an aspect ratio distortion of which the user should be
aware.

In less technical terms, the above paragraph can be summed up as
follows: a large, square area should appear square on the map.

In practice, most small-area maps (maps which cover tens of miles)

of midlatitude regions will meet these criterion. The series of 7.5
and 15 topographic maps, available from the United States
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Geological Service, will suffice. Maps based on the UTM coordinate
system are acceptable. |

- It must be possible to determine the user coordinates of two easy-
to-locate points on the map. The user coordinate system must be a
Cartesian system such that the positive Y axis points true north,
and the positive X axis points east. This is the same system used to
locate the grid origin, burst location, etc.

These two points are called reference points. For maximum
accuracy, they should be ‘'far apart’' on the map.

Often, it will be possible to use the ends of the map's scale as the
reference points. The scale will often run east-west or north-
south. Suppose we had a map in which up was true north, and on
which the scale ran east-west and was 5 miles long. We could let
the left end of the scale be reference point 1, with coordinates (0,
0) miles, and the right end be reference point 2, with coordinates
(5, 0) miles. ‘ - '

- The area of interest on the map, including the two reference points,
must fit into the active area of the digitizing pad or plotter. It will
often be possible to prepare an otherwise unusable map for use
through judicious cutting, pasting, and/or photocopying. Beware of
the photocopying distortion mentioned above, however.

After finding a suitable map, prepare it for digitizing. If you are using a
digitizing pad, tape the map to the active surface of the pad. If you are
using a plotter, insert it into the machine according to the manufacturer's
instructions.

The plotter or digitizing pad can send Airrad the coordinates of any user
selected point on the map. However, the coordinates sent are the device
coordinates of the plotter or pad, and what we desire is the corresponding
user coordinates. A function which translates any set of device
coordinates into their corresponding user coordinates can be found by a
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process called aligning the map device. What we will do is select two
distinct points (the reference points) and manually enter their user
coordinates through standard numeric window entries. We will then use
the plotter or pad to indicate the two points on the map. This will send
Airrad the device coordinates of the points. Having both the user and
device coordinates for two points, Airrad can then calculate the desired
function.

It should be noted that at any point, it is possible to abort the alignment
process with the Esc key.

Select >Align from the top level menu. You will be presented with a menu
which asks for the names and user coordinates of the two alignment
points you have selected. Enter the requested information. The names are
text string entries, and the coordinates are numeric entries. The names
should be sufficiently robust that it is possible to locate the described
point on the map from the name.

After entering the points, press F1. You will then be prompted to enter
the locations of the two points on the map, using the device you have
selected. See Appendix A for a discussion of the use of the digitizing
facility for different devices. Refer to your device's user's manual for
additional information.

After both points are entered, Airrad computes the transformation
function. It can then find the corresponding user coordinates for any set
of device coordinates, and- vice versa.

Important: It is the user's responsibility to realign the device if the map
should move with respect to the plotter or pad's digitizing area.

ENTERING COORDINATES FROM A MAP

After the map has been aligned, the user can enter the user coordinates of
a point directly from the map into Airrad. Go into the >Edit>Receptor
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window. Position the color bar somewhere on the row which contains the
name of the point you wish to input. Press Altl ('I' while holding the Alt
key down). Using the plotter or the digitizing pad which you have
previously aligned, indicate the point on the map. The coordinates should
appear next to the name in the Receptor window.

Now go into the >Edit>Grid window. You can enter the burst location in the
same manner as a specific receptor location. The grid corners can also be
entered, but only as a group. Move the color bar to any grid corner entry,
and press Altl. You will be requested to enter two points, which define
opposite corners of the rectangle enclosing the computational grid.

PLOTTIN NTOURS DIRECT NTO A MAP

Airrad has. the capability to draw contours directly onto a user supplied
map. Take the map you used in the previous step and insert it into the
plotter. If necessary, use a photocopy of the area of interest. Now go into .
the hazard window (AltH) ‘and select Plotter Contours on Map. Press F9.
You will be prompted to enter two reference points, exactly as you were
prompted when you previously aﬁgned the device. Enter the points and
press F1. Then use the plotter digitizing sight to indicate the locations of
the two reference points on the map which will be plotted on (See
Appendix A for additional detail). The Esc key can be used at any time to
abort this process. After the second point is entered, the plotter will
draw the selected contours on the map, properly aligned, scaled, and
rotated.

ANN TIN T ITHA DI MAP

The Airrad package includes a map digitization utility called Makemap,
which allows the user to enter and save to file a description of any map.
This file can later be called up and used to annotate a set of contours in
Airrad. See chapter 5 for a full description of the use of Makemap.
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Go into the >Map window. The top text string entry allows the input of a
map file name, the contents of which will be used to annotate Graphic
Screen and Plotter Contours. The Yes/No toggle can be used to temporarily
disable the drawing of the map.

For a demonstration of this capability, load the Airrad sample case named
Clovis, and press F9. A graphic screen plot will appear, with the map
underlying the contours.

CALCULATING FLIGHT PATH DOSAGES

Airrad is capable of calculating the total integrated radiation dosage
received by a plane flying a user selected flight plan. By setting the flight
height to 1 meter, ground based dosages may also be calculated.

The dosage calculations are performed in the >Shows>Path window. The top
nine lines of the window allow the user to specify the desired flight path.
Note that some of the entries are redundant: for example, the path begin
time may be entered using either the absolute time and date, or the
elapsed time since the burst. The entries actually entered by the user

will always be marked with a '>' at the far left side of the window. These
entries completely define a flight plan. All other entries are
automatically calculated from the '>' entries and displayed.

In the process of entering data into this window, the user may temporarily
enter a state in which the data entered does not completely define a flight
path. In this case, a 'More Data Needed' message will appear at the bottom
of the window. This indicates that the user needs to enter more data.
Since the user has not entered enough data to completely define a flight
path, Airrad will be unable to calculate the values of the non-'>' entries,
and contradictory information may be present in the window.

Whenever 'More Data Needed' does not appear at the bottom of the window,
the user may calculate the integrated dose of the currently displayed

33



flight plan by pressing the F5 key. The results will be displayed at the
bottom of the window.

The Tab key may be used to toggle the units of the numeric entries,
including the calculated dose entry. Note that the dose entry is a special
numeric entry: it is intended only to display results, so the user cannot
edit its value.

The Airrad case must have been run before path dose calculations are
performed. However, the dose integration routine is independent of the
computational grid set in the grid window. A record of the ground impact
parameters of each tracked cloud parcel is used instead, to provide
maximum accuracy which is independent of the inherent coarseness of a
large grid. The integration routine is effectively in 'Do Not Truncate'
computational mode (See Calculate Concentrations in the Computational
Option window).

The input section of this window can be divided into three distinct
sections. | | |

The first section consists of the top line of the window, and allows the
user to enter the height above ground level of the flight, which is assumed
to be level. This is a standard numeric entry.

The second section consists of the second through seventh entries. They

allow the user to define the plane heading (direction in which the plane is
flying, measured in degrees clockwise from true north), the X-Y location

of the flight path, and the velocity of the plane along it.

The user may enter this information using any combination of these
entries which completely define a flight track. For example, the user
could enter the beginning location, ending location, and flight time. The
beginning location, speed, and. heading could not be used, however (How
would you calculate the flight time?). The user would have to also supply
the flight time or distance to make a complete set of data.
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The entries actually used will always be marked with >'s along the left
edge of the window. Other entries will be automatically calculated and
displayed.

The Altl key may be used to get the beginning and ending path positions
from a map.

The third input section consists of the two lines marked 'Beginning Time'.
They allow the user to specify the time, with respect to the burst, at
which the plane begins its flight. The time may be entered in either a
relative (first entry) or absolute (second entry) fashion.

The H + entry is the time since the burst, in hours:minutes, or
days:hours:minutes, if the period is greater than 24 hours. This is a text
string entry. If one number is typed in, it is assumed to be hours. If two
numbers are typed in, separated by a colon, then they are assumed to be
hours and minutes. Entries of the form '3 or '7:: are allowed, meaning 3
hours and 7 days respectlvely

The Time and Date entries are the absolute time and date of the beginning
of the flight. The relative H + time is computed from these entries by
comparing them with the burst time and date given in the burst window.
The time may be entered in either military or AM/PM" format, and may be
either local or Greenwich, depending of which was chosen for the burst
time. The date may be given in either 'Jan 10, 88' or '1/10/88' format.

It is recommended that the user experiment with the path dosage window,
to get a feel for its operation.
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5. THE MAKEMAP UTILITY

J1_INTR TION TO MA P

The Makemap utility is a separate program which allows the user to
construct and edit map files which can later be used to annotate contour
plots on the screen and plotter. To run, use the mm bat file. This program
requires a digitizing pad to operate. See Appendix A for a short discussion
of the use of the supported digitizing pads.

2 TOMIZING MM ILE WITH MAKEMAP COMMAND LIN TION

Before using Makemap, the mm bat file must be customized to pass the
proper parameters to Makemap. Using Edlin or the text editor of your
choice, edit the file mm.bat and add the following command line
parameters to the invocation of Makemap, as approprlate No upper/lower
case distinction is required. ' '

-h <directory> = Set the home directory for Makemap to <directory>.
The home directory contains the files which Makemap
needs in order to operate. These are the .bgi and.chr
files, which are also used by Airrad. <directory> will
normally be "Airrad\Data'.

-t <pad> = Set the type of digitizing pad to <pad>. <pad> may be
CalComp 2000 or KurtalSOne.

-ta = Assume template aligned. Makemap normally prompts the user
to indicate the location of the of the command template on the
digitizer whenever it is run. -ta suppresses this prompt. If this
option is used, the template must not have been moved since it
was last aligned.

The command template may be found in Appendix D.
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Set the com port which the digitizer is connected to to #. #

-cp # =
may be either 1 or 2.
-br # = Set the baud rate for digitizer communication to #. # may be

110, 150, 300, 600, 1200, 2400, 4800, or 9600.

-p # = Set the parity for digitizer communication to #. # may be n for
none, e for even, or o for odd.

-sb # = Set the number of stop bits for digitizer communication to #.
# may be either 0, 1, or 2.

-db # = Set the number of data bits used for digitizer communication
to #. # may be either 7 or 8.

2.3 PREPARING TO DIGITIZE A MAP

The digitizer Command Template, found in Appendix D, should be placed on
the digitizer and taped in place. The map you wish to digitize should also
be placed on the pad, making sure the areas of interest fit inside the
active area of the pad's surface. This map must meet the specifications
outlined in the discussion of Outlining a Map on an External Device (4.33).

To start the Makemap utility, type mm and press enter.

4 ING T MM

When Makemap starts up, you will be asked to align the command template
on the digitizer's surface. To do so, use the digitizer stylus to indicate
the location of the small circle at the upper left corner of the command
template. Then indicate the one at the upper right corner. The command
template is now aligned. lIts location is stored in a file called
template.dat, in the Makemap home directory (See the -h command line
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option above). As long as you do not move the template, you may bypass
the alignment process in the future by pressing Enter when you first start
Makemap, or by specifying the -ta command line parameter in the mm bat
file.

2.5 ALIGNING THE MAP ON THE DIGITIZER

Before adding objects to the map, you should select 'Align Map' from the
command template, and then align the map as described in section 4.33.

I THE DIGIT! M

Symbols can be added to the digitized version of the map by selecting 'Add
Symbol' from the command template, selecting the type of symbol from
the 16 choices on the third line of the template, and then indicating the
location of the symbol.

Lines can be added by selecting 'Add Vector', indicating the location of the
start of the line on the map, and then indicating successive points.
Terminate line entry mode by pressing the Esc key. Erase the last line
segment by pressing the BackSpace key.

Text can be added by selecting 'Add Text', indicating the location of the
text on the map, and then typing in the text at the keyboard.

7 TH RENT
The last object added is known as the current object. It's color can be
changed by selecting 'Color', then choosing the desired color from the list

of 16 provided on the third row of the template.

If the current object is text, its size can be changed by selec'ging '"Text
Size', and then selecting the desired text size (1-10) from the first 10
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cells of the last row of the command template. Text justification can be
changed by selecting 'Text Justify' , then selecting the justification from
the 3 cells below 'Text Justify', marked L for left, C for center, and R for

right. '

The current object can be deleted by selecting 'Delete’ from the command
template.

An old object can be made into the current object by selecting 'Select’
from the command template, then indicating the object to be selected. It
is usually easier to select objects by watching the cursor which will
appear on the screen. An object will blink once when it is selected. Once
selected, an object becomes the current object, and all of the above
operations which apply to the current object can be used.

ILE COMMAN

‘Write the map to a disk file by selecting 'Save’. Load a previously saved
map by choosing 'Load’. Enter the file names as described in section 4.18.
A map file will be automatically given the extension '.MAP'.

When loading an old case, you will be asked to realign the device.
However, if the map has not moved since the case was last saved, you can
skip the realignment process by pressing F2 instead of F1.

Select 'New Case' to begin a new map. All old objects are discarded.

39



5.9 KEYBOARD SHORTCUTS

The following are keyboard shortcuts for template commands.

AltA Align map
AltR Redraw map

F2 Save map to a disk file

F3 Load a previously saved map
AltQ,

AltX,

F10 Quit Makemap and exit to DOS.
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APPENDIX A - ENTERING DIGITIZED POINTS

This appendix gives a short discussion of how to use the digitizing
facilities for each of the peripherals supported by Airrad. For more
information, see the user's manual for each piece of equipment.

Kurta 1S/One_Digitizing Pad - Lift the clear plastic sheet covering the

digitizing area of the pad, and place the map under it. If you are using the
stylus indicator, indicate points by placing the tip of the stylus on the
map at the desired location, and pressing down on either the tip or the
button. If you are using the crosshair indicator, align the crosshairs of
the indicator over the desired point and press the top button. Note that if
you are using the cordless version of the crosshair indicator, you must be
touching the dark gray area on both sides of the indicator for it to operate.

CalComp 2000 Digitizing Pad - Place the map down on the bed of the pad,

and tape it into place. Indicate points by placing the tip of the pen stylus
on the map at the desired location, and pressing down.

HP_GL Plotter - Use the lever to raise the pinch wheels, insert the map
into the plotter, and lower the pinch wheels. When the plotter goes into
digitizing mode, a green light will flash. Position the digitizing sight
using the four arrow buttons. Two arrow buttons may be pressed
simultaneously to achieve diagonal motion. Press the Fast button with the
arrow buttons to speed up the motion. When the desired point is visible
through the sight, press the Enter button. If you do not have a sight, a pen
(preferable a dried out one) may be used. Raise the pen by pressing the
Pen U/D button, move it to approximately the correct position, and then
lower it by pressing the Pen U/D button again. The tip of the pen will
indicate the current location. Continue this process until the tip rests
exactly on the desired map point, then press the Enter button.

The HP manual recommends that the digitizing sight not be stored in the
plotter's pen carousel. However, the author has stored his sight in the
carousel, and has never experienced any difficulty. Doing so certainly
makes the digitizing process more efficient.
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IBM_749 Plotter - Lay the map down on the plotter bed, press the Load
button to activate the electrostatic hold, and then press the Plot button.
When the plotter goes into digitizing mode, the Digitize light will flash.
Position the sight using the four arrow buttons. Press two buttons
simultaneously to achieve diagonal motion. When the desired point is
visible through the sight, press the Select button. If you do not have a
sight, a pen (preferable a dried out one) may be used. Raise the pen by
pressing the Pen button, move it to approximately the correct position,
and then lower it by pressing the Pen button again. The tip of the pen will
indicate the current location. Continue this process until the tip rests
exactly on the desired map point, then press the Enter button.
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APPENDIX B - AIRRAD COMMAND LINE OPTIONS

The following command line options may be added to the air bat file to
customize airrad to specific situations. The air.bat file should invoke
Airrad with a line of the following form...

<complete path>\Airrad -h <home directory> <options> %1 %2 %3

...where <complete path> is the directory in which the file airrad.exe
resides (usually \Airrad), <home directory> is the directory in which the
Airrad system files reside (usually \Airrad\Data), and <options> is any of
the command line options below which the user might wish to specify.
The %1 %2 %3 at the end of the line allows the user to pass explicitly

typed options to Airrad through air.bat. For example, a user might invoke
Airrad with...

air -lock
...to ‘temporarily start Airrad in file lock mode.

The command line decoder does not distinguish between upper and lower
case letters.

-lock = Start up Airrad in file lock mode. In this mode, a user must
specifically override a warning box before a case can be
saved.

-bw = Force Airrad into black and white monitor mode. Overrides
autodetection of the installed video card.

-color = Force Airrad into color monitor mode. Overrides
autodetection of the installed video card.

-cga = Force Airrad to use the CGA graphics card device driver.
-ega = Force Airrad to use the EGA graphics card device driver.
-vga = Force Airrad to use the VGA graphics card device driver.
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-herc = Force Airrad to use the Hercules graphics card device driver.

-noversion = Suppress display of the version window when Airrad
starts.

-hardware = Use only hardware flow control in communicating with
peripherals.

-xonxoff = Use only software flow control in communicating with
peripherals (Xon-Xoff).

If neither -hardware or -xonxoff is specified, both hardware and

software flow control are used. If both are specified, flow control is
effectively shut off.
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APPENDIX C - TROUBLESHOOTING

Installation Program Fails to Operate Correctly

The Airrad installation program may fail to install Airrad in a suitable
manner. This will most likely occur due to improperly made second hand
distribution disks. In such a case, attempt the following manual
installation procedure.

1.

2.

Make two directories on your hard disk: \Airrad and \Airrad\Data.

Copy all files from the \Airrad directory of the first Airrad |
distribution disk into the \Airrad directory of your hard disk.

. Copy all files from the \Airrad\Data directory of the first Airrad

distribution disk into the \Airrad\Data directory of your hard disk.

. Repeat steps 2 and 3 for each of the remaining Airrad distribution

disks.

. Add the \Airrad directory to your computer's command search path.

Use edlin, or the text editor of your choice, to edit the
\autoexec.bat file on your hard disk. Look for the line which begins
with PATH. Add \Airrad to the end of the line, separating it from
the rest of the list with a semicolon. See your DOS manual for
more information. This step is not necessary if you plan to always
cd into the \Airrad directory before you start Airrad.

As an alternative, the air.bat file can be placed in a directory
which is already in your computer's search path. The root
directory, 'V, is always in the search path, so if you are having
trouble with this step, simply copy air.bat into the root directory.
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Example: To install Airrad on the C: hard disk using the A: drive to
read the distribution disks, type the following commands.

mkdir c¢:\airrad

mkdir c:\airrad\data

copy a:airrad\*.* - c:\airrad Repeat these two steps for
copy a:airrad\data\*.* c:\airrad\data each distribution disk.

reen i r I Im i lor

Airrad attempts to determine the type of display hardware present in the
host computer and select colors appropriately. For unusual combinations
of hardware (for example, a monochrome display connected to an color
graphics board), this procedure may fail. In such a case, the user should
add command line options to the air.bat file to force Airrad into the proper
display mode. The options in question are -bw, -color, -cga, -ega, -vga,
and -herc. See Appendix B for more information.

rror r rin lottin

For certain unusual combinations of hardware, the flow control used to
manage data flow between the host computer and a plotter may
malfunction. Symptoms of this problem include the drawing of
meaningless lines by the plotter, and the locking up of the host computer
when a plot is attempted. If such problems occur, the user should
experiment with adding various combinations of the command line options
-xonxoff and -hardware to the air.bat file. These options are described in
Appendix B.
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APPENDIX D - DIGITIZER COMMAND TEMPLATE

This template is used in conjunction with a digitizer and the Makemap
utility described above. The template is placed. on the digitizer surface.
When run, Makemap will request the user to indicate the location and
orientation of the template. Subsequent to this, Makemap's action is
controlled by selecting commands from the template.
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